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Troubleshooting PsiWin 2.x 
synchronization problems 
Note: All occurrences of Revo in this document also refer to Revo Plus unless otherwise specified. 
This document discusses various problems that may be encountered when synchronizing Psion 
Agenda and Data files from the Psion Series 3a, 3c, 3mx, 5, 5mx, 7, Siena or Revo with Microsoft 
Outlook 97 or 98, Microsoft Schedule+ 7.0, 7.0a or 7.5, or Lotus Organizer 2.1, 97 or 97GS. Some 
familiarity with these applications, Windows 95/98/NT 4.0 and your Psion is assumed. You will also 
need a full installation of your PC Personal Information Manager (PIM).  
 

Setting up your synchronization correctly 
The majority of synchronization problems are caused by an incorrect synchronization set up. Please 
make sure you have read the appropriate Synchronizing your Psion with… support document first as 
these explain the correct way to set up a synchronization. In particular, you should ensure that you are 
synchronizing the correct files, both on the Psion and on the PC. 
 

How to troubleshoot a synchronization problem 
In order to troubleshoot a synchronization problem you will need several pieces of information. 
Following is a list of the information you will almost definitely need: 
1. The version of PsiWin 2.x and the Psion machine with which you are synchronizing. 

Some older versions of PsiWin 2.x will not work with as many PC PIMs as more recent versions. 
If you are unsure which version of PsiWin 2.x you are using and whether it works with your Psion 
machine, see the Synchronizing with older versions of PsiWin 2.x section towards the end of 
this document. You should also upgrade your copy of PsiWin to the latest version. Check Psion’s 
web site (www.psion.com) for details on which versions are available for download or check with 
your local Psion distributor for details of availability. 

2. Your PC’s Operating System. 
Some versions of PsiWin 2.x are incompatible with some versions of Windows. PsiWin versions 
before 2.2 will not work properly with Windows 98 and PsiWin versions before 2.1 Service 
Release 1 need to be installed by an Administrator on Widows NT 4.0. Also, if you are using 
Windows NT 4.0 you will need to have installed Service Pack 3 or later. 

3. If you can successfully connect your Psion and PC. 
If not, or if you are not sure, see the Troubleshooting PsiWin 2.x connection problems support 
document for advice. 

4. If synchronization has been successful in the past. 
If so, it is possible that something has changed on your Psion or PC. This could be an application 
causing problems with the connection between Psion and PC (see point 3 above), some software 
which changes the way your PC PIM works (for example, an Outlook plug-in) or corruption in 
one or more files. See the Deleting an Owner/Registered machine, Finding the corrupt file(s) 
and Curing corruption sections later in this document. 
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5. Any error messages, exactly as they appear on the PC. 
See the section towards the end of this document for detailed explanations of the meaning of 
numerous error messages. 

6. At which point the synchronization fails. 
A general diagnosis of the problem can be made from knowing the point at which the 
synchronization fails. 
•= If you are unable to create a synchronization, the most likely causes are a bad installation of 

PsiWin or synchronization plug-ins, or a corrupt Owner/Registered Machine. See the 
Installing and uninstalling PsiWin 2.x support document or the Deleting an 
Owner/Registered machine section later in this document. 

•= If the synchronization fails immediately or very soon after the start, the usual causes are 
incorrect information entered in the synchronization properties or an incompatible PIM being 
used. See the relevant Synchronizing your Psion with… support document for a step-by-step 
guide on setting up a synchronization, or the Synchronizing with older versions of PsiWin 
2.x for a PsiWin/PIM compatibility table. This could also be due to a corrupt 
Owner/Registered machine. 

•= If the synchronization fails or hangs before completing, or finishes with the message ‘The 
synchronization did not finish normally’, the usual cause is corruption in one of the files 
involved. See the Finding the corrupt file(s) and Curing corruption sections later in this 
document. 

 

Deleting an Owner/Registered machine 
When PsiWin 2.x connects to a machine for the first time it asks you to enter a name for that machine. 
This will register details about your Psion on your PC. Very occasionally this information can become 
corrupt. 
To delete this information, click the Start button and 
select Programs, then PsiWin 2.x, and then Machine 
Manager (Owner Manager in older versions of 
PsiWin). This will present you with a list of current 
registered machines. Highlight your machine and click 
the Remove details of selected machine button (Delete 
this owner in older versions of PsiWin). The next time 
you connect your Psion you will be asked to give it a 
name. At this point you should type in something 
different from the machine name you have just deleted.  
After doing this you should make a new backup and recreate any synchronizations.  
 

Finding the corrupt file(s) 
By far the most common cause of a synchronization failing, apart from the wrong files being chosen 
in the set up, is corruption or spurious entries in one of the files.  
To test whether this is the case, create a new Psion Agenda and/or Data file, and new Outlook folders, 
Schedule+ file or Organizer file and put one test entry in each. If this synchronization works then the 
problem is with one of the original files. If not, you should reinstall PsiWin. See the Installing and 
uninstalling PsiWin 2.x support document for information on how to do this. 
The next steps are to find out which file is causing the problem. Ignore any of the steps below that do 
not apply to you. For example, if you are only synchronizing an Agenda file with your PIM, ignore 
step 3. 
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1. Synchronize new Psion Agenda/Data files (see the section in this document on Creating new 
files), as necessary, with your existing PIM file. If this works, the problem lies in either the 
Agenda or Data file. If not, there is a problem with your PIM file. 

2. Synchronize a new Schedule+ or Organizer file, or new Outlook folders (see the section in this 
document on Creating new files) with the existing Agenda file. If this does not work, there is a 
problem with your Psion Agenda file. 

3. Synchronize a new Schedule+ or Organizer file, or new Outlook folders (see the section in this 
document on Creating new files) with the existing Data file. If this does not work, there is a 
problem with your Psion Data file. 

 

Creating new files 
Agenda  
If you are using a Series 3a, 3c, 3mx or Siena, you can create a new Agenda file in one of two ways. 
The first is to highlight the Agenda icon on the System screen and press Psion + N or select New file 
from the File menu. Type in a name for the file and press Enter. The second way is to press Psion + 
N or select New file from the File menu within an open Agenda file, then type in a name for the file 
and press Enter. 
If you are using a Series 5, 5mx, 7 or Revo, you can create a new Agenda file in one of two ways. The 
first is to highlight the Agenda icon on the System screen and press Ctrl + N or select Create new 
then File… from the File menu. Type in a name for the file and tap the OK button or press Enter. 
The second way is to press Ctrl + N or select Create new file from the File menu within an open 
Agenda file, then type in a name for the file and tap the OK button or press Enter. 
 
Data  
If you are using a Series 3a, 3c, 3mx or Siena, you can create a new Data file in one of two ways. The 
first is to highlight the Data icon on the System screen and press Psion + N or select New file from 
the File menu. Type in a name for the file and press Enter. The second way is to press Psion + N or 
select New file from the File menu within an open Data file, then type in a name for the file and press 
Enter. You should then set up the labels so they are the same as the original file. 
If you are using a Series 5, 5mx, 7 or Revo, you should create a new Data file from within the original 
Data file. Press Psion + N or select New file from the File menu and tap the OK button or press 
Enter. This will copy the label structure from the original Data file into the new file. 
 
Outlook  
To create a new Outlook folder, select New, then 
Folder from the File menu. Type in a name for this 
folder (in this example, Test) and select which type of 
information this folder is going to contain (this should 
be the same as the folder you are exporting, in this 
example, Appointment Items). Then, select the top-
level folder in the list of folders (in this example, 
Personal Folders) and click the OK button.  
The new folder will appear in the folder view in 
Outlook (if you have this showing).  

  

Schedule+  
To create a new Schedule+ file select New from the File menu. Then type a name for the new file in 
the File name: box, for example, Test, then click the Save button.  
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Organizer  
To create a new Organizer file, select New from the File menu. 
 

Curing corruption 
The following sections describe how to cure corruption in Psion files and supported PC PIMs. After 
following the instructions you will need to specify the new file(s) in the synchronization properties. 
 
Agenda files 
1. If there is a problem with your Series 3a, 3c, 3mx or Siena Agenda, you should perform a 

Tidy/extract operation on the file. 
To do this, open the Agenda file and press 
Psion + T. Change the Tidy/extract line to 
Copy to file, enter a file name (in this 
example, Test) and the disk to create this file 
on. Then, select Whole Agenda on the Range 
line, All entries on the Status filter line and 
press Enter.  
This will extract all the information from your Agenda into a new file (in this example, Test). 
Note that this is not the same as copying the file. 

2. If there is a problem with your Series 5, 5mx, 7 or Revo Agenda, you should perform a 
Tidy/archive operation on the file. 
To do this, open the Agenda file, and select 
More, then Tidy/archive from the File 
menu. Change the Tidied entries are line to 
Copied to new file. Select All entries on the  
Which entries line and change the Range 
line to Whole agenda. Enter a file name (in 
this example, Test) and select a folder and 
disk to create the file in. Then tap the OK 
button or  
press Enter. This will extract all the information from your Agenda into a new file (in this 
example, Test). Note that this is not the same as copying the file. 

 
Data files 
1. If there is a problem with your Series 3a, 3c, 3mx or Siena Data file, you should perform a Merge 

in operation on the file. 
Create a new file and in that file press Psion + M. In 
the Merge in dialog change the Disk line to the disk 
on which your original Data file is kept, and select the 
filename on the From: Name line. Change the Merge 
in line to Data. Then press Enter. 

2. If there is a problem with your Series 5, 5mx, 7 or Revo Data file, you should perform a Merge in 
operation on the file. 
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Create a new file and in that file press Shift + Ctrl + 
I. In the Merge in file dialog, change the Disk and 
Folder lines to the disk and folder on which your 
original Data file is kept, and select the filename on 
the Name line. Then tap the OK button or press 
Enter. 
  

PC PIM 
If there is a problem with your PC PIM file, you will need to export the information as text and import 
it into a new file or folder. 
 
Outlook  
1. Open the original Outlook file and select Import and 

Export from the File menu. Then highlight Export to 
a file and click the Next button.  

2. Select the folder you wish to export (in this case Calendar). And click the Next button. 
3. Select Comma Separated Values (Windows) and 

click the Next button. 

4. Type in a name for the export file (in this example, 
Calendar.txt) and click the Next button. Then click 
the Finish button. 

 

5. To import the information into a new folder, select 
Import and Export from the File menu. Then select 
Import from Schedule+ or another program or file 
and click the Next button. 

6. Select Comma Separated Values (Windows) and 
click the Next button. 

7. Type in the name you gave the export file (in this 
example, Calendar.txt) and click the Next button. 

8. Select a new folder (in this example, Test) and click the Next button. Then 
click the Finish button. 

You may need to do this for each Outlook folder with which you are 
synchronizing. 
Note: It may also be necessary to set up a new Outlook profile and import the 
data into this. See the relevant section later in this document for information 
about creating a new Outlook profile. 
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Schedule+ 7.x  
1. Open the original Schedule+ file, and select Export, then Text from the File 

menu. Then select the type of items you wish to export (in this example, 
Appointments) and click the Next button. 

2. Select the date range you wish to export and click the Next button. 
3. In the next two dialogs accept the defaults by clicking the Next 

button twice. 
 

4. Click the Add All button to export all the fields and 
then click the Next button. 

5. Type in a name for the export file, or accept 
the default, and click the Finish button. 

 

6. To import the information, open a new Schedule+ 
file by selecting Open, then Archive or Project 
Schedule from the File menu.  

 

7. In this file, select Import, then Text from the File menu.  
8. Type in the path and name of the export file. If you accepted the default when exporting, this 

should already be entered. Then click the Next button. 
9. Accept the defaults in the next two dialogs by clicking the Next button twice.  
10. Select the type of data in the export file (in this example, Appointments) and then 

click the Next button. 

 
11. On the final screen, you need to map the fields 

between the two Schedule+ files. Opposite 
each field, to its right it will say IGNORE 
THIS FIELD. Click on this and a down arrow 

 will appear. Click on this and a list of field 
types will appear. Select the type that 
corresponds to the field on the left. Do this for 
all the fields and click the Finish button.  

You may need to do this for each type of 
information with which you are synchronizing. 
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Organizer  
1. Open the original Organizer file and select 

Export from the File menu. On the From 
section line, select the section that you wish 
to export (in this example, Calendar), select 
ASCII Delimited Text on the Files of type 
line and type in a file name (in this example, 
Calendar.txt). Then click the Export button. 

2. To import the information, open a new 
Organizer file and select Import from the 
File menu. On the Into section line, select 
the section into which you wish to import the 
information (in this example, Calendar), 
select ASCII Delimited Text on the Files of 
type line, and select the file you exported to 
earlier (in this example, Calendar.txt). Then 
click the Import button.  

You should also check your PC PIM for spurious entries such as: 
•= Repeating entries with only one occurrence. 
•= Alarmed entries with a reminder set for before 1980. 
•= Entries with a carriage return at the end of the subject line. 
•= In Outlook, entries with a ‘crossed swords’ symbol. Double-click on the symbol to resolve the 

problem. 
 

Creating a new Outlook Profile 
This will only be of use if, after importing information into a new folder, testing reveals that there is 
still a problem with Outlook. This should only be attempted if you have a non-networked copy of 
Outlook. If you use Outlook on a network that is running Exchange, you should contact your Network 
Administrator. 
To create a new Outlook profile:  
1. Click the Start button, select Settings, then Control Panel. Double-click the Mail and Fax icon 

(this icon may be called Mail if you are using Outlook 98).  
2. In the Properties dialog, click the Show profiles button. This will show a list of all the Outlook 

profiles on the PC. Then click the Add button. 
3. Select Manually configure information services and click 

the Next button. 
 

4. Type in a profile name (in this example, Test) and 
click the Next button. 

5. In the Properties dialog click the Add button to add an information service to the new profile. 
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6. Highlight Personal Folders and click the OK button. 

7. Type in a name for the Outlook file (in this example, Test.pst) and click the 
Open button. 

8. Select No encryption and click the OK button. 
9. Click the OK button again and then the Finish button. Click the Close button to exit the Wizard. 
10. Open Outlook, and select Options from the 

Tools menu. On the General page, select 
Prompt for a profile to be used and click 
the OK button.  

The next time you start Outlook you will be asked which profile you wish to use. 
 

Other problems 
This section describes solutions to other problems that can occur with a synchronization. 
 
Microsoft Outlook: Failed to open Outlook 
This error message can appear just after the start of the synchronization 
process. There can be two reasons for this message appearing.  
The first is that your Outlook profile has been incorrectly entered. 
To check this, first make sure you have your profile name. 

You can find this in Outlook by selecting Options from the Tools menu. On the General page, if 
Always use this profile is selected your profile name will be in the text box next to it. If Prompt for 
a profile to be used is selected, your profile name is the one you select when you start up Outlook.  
Follow the Synchronizing your Psion with Microsoft Outlook support document to ensure that this 
information has been entered correctly in the synchronization properties. 
The second reason is that the path to the Outlook folder(s) you are synchronizing 
has been incorrectly specified. To check the path to the folder, make sure you can 
see the Folder view in Outlook. To show it, select Folder view from the View 
menu.  
In the example shown here, if you were trying to synchronize the Example 
folder, the path would be: 
 Personal Folders\Contacts\Example 
If you have a top level folder that looks like  
 Mailbox – [Chris Dickins] or 
 Outlook Today – [Chris Dickins] 
then the path would be: 
 Chris Dickins\Contacts\Example 
Follow the Synchronizing your Psion with Microsoft Outlook support document to ensure that this 
information has been entered correctly in the synchronization properties. 
 
Microsoft Outlook: Failed to open Custom form, Outlook will open an Outlook form 
instead 
This error message is due to conflicting entries. Find the Outlook entries that have a ‘crossed swords’ 
symbol. Double-click this symbol to resolve the conflict and the problem should be solved. 
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Lotus Organizer 2.1: Synchronizer cannot access required directory 
This is due to the incorrect version of a particular file (the Organizer API) being loaded.  
To find this file, click the Start button, select 
Find, then Files or folders. On the Named: line, 
type orgapi.dll and make sure that the Look in: 
line is set to your C drive (or whichever drive the 
Organizer files were installed to). Then click the 
Find now button. You should get a list of two 
copies of the file. Right-click on each in turn and 
select Properties. One of the files should have a 
Modified date of 7th November 1995. Right-click 
again on the file with this date and select Delete. 
Then confirm the deletion and restart the PC. All 
should now be well. 

 
 
Lotus Organizer: Cannot find xxxxxxx (section name) 
This error message is due to the section name being incorrectly entered in the 
synchronization properties. Open Organizer and check the name of the relevant section. 
Then enter the section name in the synchronization properties (the Synchronizing your 
Psion with Lotus Organizer support document shows you how to do this). 
 
Lotus Organizer: Unable to open xxxxxxx (section name) 
This is due to a problem in Organizer where, if you rename a section, Organizer will 
sometimes not recognise the change. The solution here is to rename the section back to 
its original name and change the synchronization properties to reflect this.  
To do this, right-click on the relevant section’s tab. 
Select Rename, type the original name on the New 
name line, then click the OK button. Follow the 
Synchronizing your Psion with Lotus Organizer 
support document and enter this information in the 
synchronization properties 
 
Error Code: Agenda Model 
Error Number: 10 
While this is not, strictly speaking, a synchronization problem, it does occur as the result of a 
synchronization. If you find that, after synchronizing, your Agenda fails to open with this error 
message, you will need to do two things. First, delete the Agenda file as it is now unusable. Second, 
search your PIM for alarmed entries with a reminder set for before 1980 and either delete these entries 
or modify them so that the reminder is set for a date after 1980.
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Synchronizing with older versions of PsiWin 2.x 
The user interface of older versions will differ slightly from PsiWin 2.4 shown here, but all the 
information required is the same. Below is a table showing compatibility between versions of PsiWin 
and PC PIMs. To find out which version of PsiWin 2.x you have, double-click the My Psion icon on 
your desktop and select About PsiWin 2.x from the Help menu. 
PsiWin version Supported PIMs 
2.0 (Builds 042, 046 and 051) Microsoft Schedule+ 7.0/7.0a, Lotus Organizer 2.1/97 
2.01 (Build 055) Microsoft Schedule+ 7.0/7.0a, Lotus Organizer 2.1/97 
2.01 with Office 97 plug-in Microsoft Schedule+ 7.0/7.0a, Microsoft Outlook 97, Lotus 

Organizer 2.1/97 
2.1 (Build 072) Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97, Lotus 

Organizer 2.1/97 
2.2 (Build 097) Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97/98, Lotus 

Organizer 2.1/97/97GS 
2.3 (Build 138) Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97/98, Lotus 

Organizer 2.1/97/97GS 
2.3 (Build 138) with email 
synchronization plug-in 

Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97/98 (inc. 
email), Lotus Organizer 2.1/97/97GS, Lotus cc:Mail 6/8 (with 
cc:Mail 8 post office) email 

2.31 (Build 142) Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97/98, Lotus 
Organizer 2.1/97/97GS 

2.31 (Build 142) with email 
synchronization plug-in 

Microsoft Schedule+ 7.0/7.0a/7.5, Microsoft Outlook 97/98 (inc. 
email), Lotus Organizer 2.1/97/97GS, Lotus cc:Mail 6/8 (with 
cc:Mail 8 post office) email 

Note: Lotus Organizer 4.1 is the same as 97GS 
In addition, versions before PsiWin 2.2 cannot synchronize with the Psion Series 3a, 3c, 3mx or Siena. 


	Troubleshooting PsiWin 2.x synchronization problems
	Setting up your synchronization correctly
	How to troubleshoot a synchronization problem
	Deleting an Owner/Registered machine
	Finding the corrupt file(s)
	Creating new files
	Agenda
	Data
	Outlook
	Schedule+
	Organizer

	Curing corruption
	Agenda files
	Data files
	PC PIM
	Outlook
	S
	Organizer

	Creating a new Outlook Profile
	Other problems
	Microsoft Outlook: Failed to open Outlook
	Microsoft Outlook: Failed to open Custom form, Outlook will open an Outlook form instead
	Lotus Organizer 2.1: Synchronizer cannot access required directory
	Lotus Organizer: Cannot find xxxxxxx (section name)
	Lotus Organizer: Unable to open xxxxxxx (section name)
	Error Code: Agenda Model�Error Number: 10
	PsiWin version



